Over-Constraining and Driven Dimensions

- We can use Autodesk Inventor to build partially constrained or totally unconstrained solid models. In most cases, these types of models may behave unpredictably as changes are made. However, Autodesk Inventor will not let us over-constrain a sketch; additional dimensions can still be added to the sketch, but they are used as references only. These additional dimensions are called driven dimensions. Driven dimensions do not constrain the sketch; they only reflect the values of the dimensioned geometry. They are enclosed in parentheses to distinguish them from normal (parametric) dimensions. A driven dimension can be converted to a normal dimension only if another dimension or geometric constraint is removed.

1. Select the General Dimension command in the Sketch toolbar.

2. Select the vertical line.

3. Pick a location that is to the right side of the triangle to place the dimension text.

4. A warning dialog box appears on the screen stating that the dimension we are trying to create will over-constrain the sketch. Click on the Accept button to proceed with the creation of a driven dimension.

5. On your own, modify the angle dimension to 35° and observe the changes of the 2D sketch and the driven dimension.

- Note Inventor has indicated the sketch is Fully Constrained.
Deleting Existing Constraints

1. On your own, display all the active constraints if they are not already displayed. (Hint: Use the Show Constraints command in the Sketch toolbar or Show All Constraints in the option menu.)

2. Move the cursor on top of the Fix constraint icon and right-mouse-click once to bring up the option menu.

3. Select Delete to remove the Fix constraint that is applied to the lower right corner of the triangle.

   Note the removal of the Fix constraint has caused the need for two additional dimensions.

4. Drag the top corner of the triangle and note that the entire triangle is free to move in all directions. Drag the corner toward the top right corner of the graphics window as shown in the above figure. Release the mouse button to move the triangle to the new location.

5. On your own, experiment with dragging the other corners and/or the three line segments to new locations on the screen.

   Dimensional constraints are used to describe the SIZE and LOCATION of individual geometric shapes. Geometric constraints are geometric restrictions that can be applied to geometric entities. The constraints applied to the triangle are sufficient to maintain its size and shape, but the geometry can be moved around; its location definition isn't complete.
6. On your own, reapply the **Fix** constraint to the lower right corner of the triangle and delete the reference dimension.

7. Delete the extra reference dimension and confirm the same constraints and dimensions are applied on your sketch as shown.

   💡 Note that the sketch is fully constrained.

8. Click on the **Display/Hide Constraints** button in the status toolbar to hide all the constraints.

### Using the Auto Dimension Command

➢ In *Autodesk Inventor*, the **Auto Dimension** command can be used to assist in creating a fully constrained sketch. **Fully constrained** sketches can be updated more predictably as design changes are implemented. The general procedure for applying dimensions to sketches is to use the **General Dimension** command to add the more critical dimensions, and then use the **Auto Dimension** command to add the additional dimensions/constraints to fully constrain the sketch. The **Auto Dimension** command can also be used to apply the missing dimensions that are needed. It is also important to realize that different sets of dimensions and geometric constraints can be applied to the same sketch to accomplish a fully constrained geometry.

1. Click on the **Auto Dimension** icon in the **2D Sketch** panel.

   💡 Note that *Autodesk Inventor* confirms that the sketch is fully constrained with the message “**0 Dimensions Required.**”

2. Click **Done** to exit the **Auto Dimension** command.
3. Select the **Center point circle** command by clicking once with the left-mouse-button on the icon in the **Sketch** toolbar.

4. On your own, create a circle of arbitrary size inside the triangle as shown below.

5. Click on the **Auto Dimension** icon in the **2D Sketch** panel.
   - Note that *Autodesk Inventor* confirms that the sketch is not fully constrained and "3 Dimensions Required" to fully constrain the circle. What are the dimensions and/or constraints that can be applied to fully constrain the circle?

6. Click **Done** to exit the **Auto Dimension** command.

7. Click on the **Tangent** constraint icon in the **Sketch** toolbar.
8. Pick the circle by left-mouse-clicking once on the geometry.

9. Pick the inclined line. The sketched geometry is adjusted as shown.

10. Inside the graphics window, click once with the right-mouse-button to display the option menu. Select OK in the popup menu to end the Tangent command.

- How many more constraints or dimensions do you think will be necessary to fully constrain the circle? Which constraints or dimensions would you use to fully constrain the geometry?

11. Move the cursor on top of the right side of the circle, and then drag the circle toward the right edge of the graphics window. Notice the size of the circle is adjusted while the system maintains the Tangent constraint.

12. Drag the center of the circle toward the upper right direction. Notice the Tangent constraint is always maintained by the system.

> On your own, experiment with adding additional constraints and/or dimensions to fully constrain the sketched geometry. Use the Undo command to undo any changes before proceeding to the next section.
13. Inside the graphics window, click once with the **right-mouse-button** to display the option menu. Select **Create Constraint → Coincident** in the popup menus.

- The option menu is a quick way to access many of the commonly used commands in *Autodesk Inventor*.

14. Pick the vertical line.

15. Pick the center of the circle to align the center of the circle and the vertical line.

16. On your own, **delete** the Coincident constraint we just applied and add a Coincident constraint between the center of the circle and the horizontal line.

- How many more constraints or dimensions do you think will be necessary to fully constrain the circle? Which constraints or dimensions would you use to fully constrain the geometry?
The application of different constraints affects the geometry differently. The design intent is maintained in the CAD model's database and thus allows us to create very intelligent CAD models that can be modified/revised fairly easily. On your own, experiment and observe the results of applying different constraints to the triangle. For example: (1) adding another Fix constraint to the top corner of the triangle; (2) deleting the horizontal dimension and adding another Fix constraint to the left corner of the triangle; and (3) adding another Tangent constraint and adding the size dimension to the circle.

17. On your own, modify the 2D sketch as shown below.

➢ On your own, use the Extrude command and create a 3D solid model with a plate thickness of 0.25. Also experiment with modifying the parametric relations and dimensions through the part browser.

**Constraint and Sketch Settings**

- Select Application Options in the Tools pull-down menu. Click on the Sketch tab to display and/or modify the constraint settings. On your own, adjust the settings and experiment with the effects of the different settings.

- Confirm the Snap to grid option is set to OFF before proceeding to the next section.
The BORN Technique

In the previous chapter, we have chosen the first feature to be an extruded solid object. All subsequent features, therefore, are built by referencing the first feature, or base feature. The base feature is the center of all features and is considered to be the key feature of the design. This approach places much emphasis on the selection of the base feature. In most cases, this approach is quite adequate and proper in creating the solid models.

A more advanced technique of creating solid models is what is known as the “Base Orphan Reference Node” (BORN) technique. The basic concept of the BORN technique is to use a Cartesian coordinate system as the first feature prior to creating any solid features. With the Cartesian coordinate system established, we then have three mutually perpendicular datum planes (namely the XY, YZ, and ZX planes) available to use as sketching planes. The three datum planes can also be used as references for dimensions and geometric constructions. Using this technique, the first node in the history tree is called an “orphan,” meaning that it has no history to be replayed. The technique of creating the reference geometry in this “base node” is therefore called the “Base Orphan Reference Node” (BORN) technique.

Autodesk Inventor automatically establishes a set of reference geometry when we start a new part, namely a Cartesian coordinate system with three work planes, three work axes, and a work point. All subsequent solid features can then use the coordinate system and/or reference geometry as sketching planes. The base feature is still important, but the base feature is no longer the ONLY choice for selecting the sketching plane for subsequent solid features. This approach provides us with more options while we are creating parametric solid models. More importantly, this approach provides greater flexibility for part modifications and design changes. This approach is also very useful in creating assembly models.

Sketch Plane Settings

1. Select Application Options in the Tools menu as shown.

![Application Options](image)

- The Application Options menu allows us to set behavioral options, such as color, file locations, etc.
2. Click on the **Part** tab to display and/or modify the default sketch plane settings.

- Note the option to setup the sketch plane to be used during new part creation is available. Confirm the **No new sketch** option is set as shown.

3. Click on the **Sketch** tab to examine/modify the default sketching settings.

4. Turn **OFF** the **Snap to grid** option, if you have not already, and **Look at sketch plane on sketch creation** options.

5. Click on the **Close** button to accept the setting.

6. Click on the **New** icon in the **Standard** toolbar.

Applying the BORN Technique

1. In the part browser window, click on the [+] symbol in front of the Origin feature to display more information on the feature.

   - In the part browser window, notice a new part name appeared with seven work features established. The seven work features include three workplanes, three work axes, and a work point. By default, the three workplanes and work axes are aligned to the world coordinate system and the work point is aligned to the origin of the world coordinate system.

2. Inside the browser window, move the cursor on top of the third work plane, the XY Plane. Notice a rectangle, representing the workplane, appears in the graphics window.

3. Inside the browser window, click once with the right-mouse-button on XY Plane to display the option menu. Click on Visibility to toggle on the display of the plane.

4. On your own, repeat the above steps and toggle ON the display of all of the workplanes, work axes, and the center point on the screen.

5. On your own, use the Dynamic Viewing options (ViewCube, 3D Orbit, Zoom and Pan) to view the default work features.
By default, the basic set of work planes is aligned to the world coordinate system; the work planes are the first features of the part. We can now proceed to create solid features referencing the three mutually perpendicular datum planes. Instead of using only the default sketching plane as the starting point, we can now select any of the work planes as the sketching planes for subsequent solid features.

6. In the Sketch panel select the Create 2D Sketch command by left-clicking once on the icon.

7. In the Status Bar area, the message: “Select face, workplane, sketch or sketch geometry,” is displayed. Autodesk Inventor expects us to identify a planar surface where the 2D sketch of the next feature is to be created. Move the graphics cursor on top of XZ Plane, inside the browser window as shown, and notice that Autodesk Inventor will automatically highlight the corresponding plane in the graphics window. Left-click once to select the XZ Plane as the sketching plane.

8. Single left-mouse-click to activate the Home View option as shown. The view will be adjusted back to the default isometric view.

Note the alignment of the sketch plane to the XZ plane as shown.